Original Post

Greetings to everyone on this nice forum! I’m 133MHz, a 21 year old guy with a passion for retro gaming and electronics. I participate from another Nintendo retro gaming related community called Famicom World, in case somebody knows it and wonders if I’m the same guy ;-).

A few days ago I got my hands on a non-working Virtual Boy system with four games. It doesn’t power up, and it seems that the previous owner made a makeshift AC adapter tap because I’ve found remains of soldered wires on the battery pack contacts on the back of the controller.

My main suspect is the Voltage Regulator Module (U8). I was able to trace most of its pinout but there’s still one pin that I can’t quite identify:

Looking directly at the front of the regulator (the side with the big inductor):

1 2 3 (space) 4 5

1: Battery Voltage In
2: Ground
3: ???

4: Regulated +5V Output
5: Ground

I’m getting battery voltage on Pin 1, but there’s only 1.01 V on Pin 4 (I have traced this line to Pin 14 of U7 (74HC04) which tells me that there should be 5V on this pin) and 0.4 V on Pin 3. Also there’s a dimly-glowing red LED on the other side of U8.

Disconnecting Pin 3 and 4 from the main PCB raises the voltage of Pin 4 to 3.5 V, but Pin 3 keeps constant at 0.4V .

I’ve tried removing U8 and injecting 5V directly into the main PCB from the output of a 7805. Unfortunately, the VB seems as dead as before and the 7805 overheats pretty quickly, even though the 5V voltage is now correct across the board.

Suspecting a short circuit somewhere, I’ve disconnected everything from the main PCB (Servo PCB, Audio amp, Eye displays and Cartridge) and tried to power up the bare main board, but the 7805 still rapidly overheats and none of the other chips seem to get even warm. A short circuit on the mainboard should explain the voltage drop on Pin 4 of U8, but doing a resistance check between the 5V line and Ground doesn’t show anything abnormal, no obvious short circuits or low resistance paths.

I’ve hit a brick wall here. I think that I’m missing a critical piece of information, like the purpose of Pin 3 on the Voltage Regulator Module (U8). It keeps a constant 0.4 V which seems too low for me, but I don’t know if this is another voltage rail or if it is some kind of regulation feedback pin / low battery signal. I have traced this pin to Pin 2 of the Servo PCB, Pin 7 of the Cartridge Slot, Pin 53 of U1 (NVC), Pin 71 of U2 (VPU) and Pin 18 of U3 (VSU). Unfortunately, Pin 7 isn’t labeled on the VB Cartridge Connector Pinout, and that means that there’s no way that I can figure out the correct voltage for Pin 3 of U8 without a working VB system to make measurements on.

It would help me immensely if someone could provide me with the correct operating voltages of U8 and/or a complete pinout. And of course, every piece of technical advice will be greatly appreciated. I really want to get this bad boy up and running because I have never played the VB before (I don’t know anyone that owns a VB) and I really want to experience it :-D.

Thanks guys!

15 Replies

I just checked my notes and I don’t have a good description of pin 3 either… but I do know that you can power it w/ 5V directly on the 5V rail. Why do you suspect a short circuit, if when you connect 5V from a 7805, you actually get 5V across the board? IIRC the VB draws ~250-350mA@5V, so it’s pretty realistic to believe a 7805 w/o a heatsink would overheat quickly (especially w/ a high-ish input voltage). You should measure the current going to the 5V rail w/ an ammeter.

About the actual function of pin 3, I’d guess it’s some sort of status or reset pin… I’ve never watched it on a scope, but maybe it stays high until the +5V is stable, then goes low to start everything up (just a guess).

Have you tried actually putting a game in with everything hooked up and driving it w/ 5V directly on the 5V rail? You can power that from any convenient 5V spot, like the 5V pin on the controller port, link port, game port, etc. You might want to use a more robust supply than a bare 7805 (or at least heatsink it). I typically use a modified AT computer power supply as my bench supply (20A@5V), but you could even use an old cell phone charger or other regulated 5V supply. From what you describe, it sounds like someone that didn’t know what they were doing (or were careless) was screwing around trying to make an AC adapter and fried the regulator (not that they couldn’t have fried something else as well though).


Yeah, there are obvious burn marks around the battery contacts, no doubt that somebody with little soldering experience tried to hook up an AC adapter to it.

I have followed your advice and tried powering up the VB from a real 5V supply, the one that I use for my external hard drive which puts out 5V at 2A. I’m injecting the 5V directly through the controller port. Connected everything back together, put a game in and now there’s some progress!

The mirrors start to oscillate for a second or two and then stop. Apart from that, there’s no more signs of life from it. No light from the LED arrays, sound or any activity that the computer is running. Voltage is now pretty stable which rules out a possible short circuit. This is with U8 removed from the main PCB.

Still intrigued by the mystery of Pin 3, I have checked the voltage on it and it varies randomly between 1.3 and 1.8 V. I’ve noticed that when I touch Pin 3 with my multimeter probe, the mirrors stop oscillating, and if I turn on the power with the probe on Pin 3, the mirrors never move. I suspect that the internal impedance of my multimeter is having an effect on this line and it may well be a logic status pin as you said.

So I’ve decided to put the status pin theory to the test and tried to pull Pin 3 low and high through a 4.7kΩ resistor. When Pin 3 is pulled low, the system appears completely dead, just like with the multimeter lead on it. By pulling it high through the resistor, it seems to spring to life somewhat more. Now the mirrors keep oscillating and never stop, but again that’s the only sign of life that it gives, nothing else seems to come up besides the vibrating mirrors.

I’ve tried replacing U8 just for its “pin 3 functionality” by connecting pin 2 and 3 to the main PCB, while powering pin 1 with 12V and the VB with 5V, but it’s just as dead as when pin 3 is pulled low. Pin 3 reads about 0.3V so I presume that U8 is completely busted.

It seems that a certain behavior on pin 3 is essential for a successful startup but I still can’t figure out what it exactly does, and without a working measurement for comparison it’s like peeing in the dark, at a friend’s house.

DogP, thank you very much for your help! πŸ˜‰

Hmm… I’m not sure then… I’ve never had a problem with a VB that wouldn’t execute code, but I’ve also never had one w/ a blown regulator, so it’s likely that somebody did something really stupid, and could have blown more than just the regulator.

If you haven’t already, I’d try powering it up w/ a game in the slot (the system won’t do anything w/o a game in it), and hold pin 3 low for a short period, then drive it high. It sounds like without the regulator, that’s a floating input, which is why it acts weird (resetting after a few seconds and the multimeter probe holding it in reset). The mirrors should be oscillating if the system is going to do anything, so it sounds like low is reset (and probably held in reset until the pin goes high, like a power good status pin). If you connect it to a 5V supply and the status pin directly connected to power, the power might still be flakey while it tries to boot, and cause a lockup. If you make sure your 5V is good before connecting that, hopefully it’d work like it’s supposed to. If I get a few spare minutes tomorrow, I’ll try hooking my scope up to the pins and watch the power up.

If you have a logic analyzer or oscilloscope, you should check the address and data lines. That could tell you whether it’s actually trying to execute code, or if everything is just totally dead. You could probably get some idea from a logic probe as well. Also, make sure the mirror oscillation is stable. I think the mirrors also have a mirror stable status pin, because IIRC if you manually stop a mirror, it stops displaying (I don’t remember if it resets or just stops outputting video though).


Wheee!! It’s mostly working now!! πŸ˜€

Today I’ve tried following your suggestion of keeping pin 3 low while applying power and driving it high after a second or two, and now it starts up correctly! Both LED arrays come on and the picture is quite stable on both eyes!

I’ve tested all of my four games: Galactic Pinball, Mario Clash, Mario’s Tennis, and Wario Land. All of them display a warning screen telling you to read the instruction booklet before operating in English and Japanese, but I can’t get past that point. Wario displays its message in a different font.

I do get different sounds depending on the game:

Galactic Pinball: Weird looping random tunes that sound like a crazy remix or some serious circuit bending going on.
Mario Clash: Same as above, but it lasts for a few seconds and doesn’t loop.
Mario’s Tennis: This one plays a recognizable music track from the game, but I don’t know exactly what it is.
Wario Land: Silence.

I don’t think I should be getting music at this point, especially when it seems to be frozen at the warning screen, but again I’ve never played the VB before so I don’t know what to expect. Also I only seem to get sound through the left channel, both on headphones and external speakers. I’ve attached sound recordings from the games in case they could help identify the problem.

The controller doesn’t seem to respond but it’s hard to pinpoint if it’s a controller issue or a system issue, without a spare VB controller for testing.

In the meantime I’m going to buy a can of contact cleaner and apply standard troubleshooting techniques like looking for cold solder joints and stuff like that, just in case it’s a simple problem like a dirty or loose cartridge slot.

Again, thank you very much for your help DogP. Thanks to your advice I got my VB from totally dead to mostly doing what it’s supposed to! πŸ˜‰

Heheheh… those are the correct sounds… I’d say you’re close to having a fully working VB πŸ™‚ . If you download the latest Reality Boy (emulator), you can get an idea of what it should sound like (although the sound emulation isn’t perfect). It sounds like your problem now is in the controller. I think in all of those games, you need to press start to get to the next screen.

If you can’t get your VB controller working, you can rig it to work w/ an SNES or even an NES controller (although the key mappings aren’t very good). Just connect the corresponding pins to the one from the other controller (VB controller pinout: http://www.goliathindustries.com/vb/VBDiagrams.html ).

Oh… and about only one audio channel working… IIRC the audio amp for the speakers and headphones is on the small board w/ the headphone jack and volume knob. Try swapping the left and right input from the main board (IIRC it’s the middle two pins, but you should verify) to see if it’s the amp or the audio generator from the main board.


πŸ˜€ Galactic Pinball: Weird looping random tunes that sound like a crazy remix or some serious circuit bending going on.

What a top description, thats one of my most fave game music ever and your description now makes me wanna go make some twisted electro circuit bending sounds with my Kaosillator, i might have to steal your words if i ever make a track and need some kind of tag line for it.

Sorry no relevance to your problems but you do have the best helping you there with DogP on the case.

It was a controller problem after all! I’ve tried hooking up a SNES controller to it and I was able to start the games and somewhat play them (missing some buttons). Since the VB controller is based on the same serial protocol I thought that it may be possible to replace the custom control chip with two cascaded 4021 ICs, in case said IC is indeed bad. As for the audio issue, fortunately it was a problem on the amplifier board and not the main PCB.

I came up with a simple RC network hooked up to pin 3 to generate a delayed /RESET signal to make the system boot up properly. I’ve used a 47μF capacitor and a 4.7kΩ resistor for an RC time constant of approx. 250 milliseconds. It booted up perfectly every time! It was just a matter of building a small PCB with a 7805, resistor and capacitor to replace the original voltage regulator module.

Unfortunately my story doesn’t have a happy ending. I was excited about installing the replacement regulator, putting the system back together and finally playing some games, so I started etching a small PCB and installing the parts. Everything went great, but when I turned it on, nothing happened. Putting my multimeter on the 5V line revealed the horror… almost twelve volts. I mistakenly fitted a 7812 regulator instead of a 7805 >:(. When I realized that it was already too late. Now my VB is gone for good πŸ™ *sniff*.

Once again I want to thank you DogP for helping me out through it. Thanks to your help I got my VB working and I think that we both learned a great deal in the process. Now there’s an easy & cheap fix for a blown U8. I’ll keep my dead VB and games in hope that I’ll stumble across another one some day.

I have a spare motherboard and control if you are interested, just PM me.

I am sure some other people here also have spare VB parts, or you could pick up a broken vb off of ebay on the cheap.

LOL, Doh! I know the feeling… I’ve done more than my share of things like that :-P. At least it’s last few seconds were probably pretty exciting… finally putting it out of its misery (and ironically, its final death was more of the same power supply abuse that killed it the first time πŸ˜‰ ).

I’m assuming you’ve checked the simple things like making sure one of the caps didn’t short and save you, right? It’s unlikely, but one time I hooked up an arcade PCB w/ the 5V and 12V swapped, but I got super-lucky and the large draw on the 5V rail overloaded the 12V@1A output on the power supply, and simply swapping the wiring to the correct way made it work.

Heh, anyway, it was nice walking through the problems w/ you… it’s rare that anyone goes much farther than just checking that their batteries aren’t dead before calling the VB dead. And if you really want a VB, you should be able to snag one on ebay cheap, since all you need is the head unit, controller, and some sort of power supply (assuming yours has the stand and eyeshade, and you already have some games).


Hi guys! There was a happy ending for my story after all! πŸ˜€
About a week ago I managed to score another broken VB for cheap, but this one was in excellent aesthetic condition, almost complete (VB, stand, controller, battery pack and Mario’s Tennis), everything worked except for the displays which were completely dead. Naturally I just swapped the entire display assembly from my dead VB and presto! Fully working VB! I’ve been hooked up on Mario’s Tennis and Wario Land since then and I love it!

Just out of curiosity I decided to check out the bad displays, and it seems that I’ve got a knack for finding heavily abused VBs, because apparently somebody tried to fix a glitchy display issue… with a blowtorch! There’s a hole burned through the flat flex cable on both displays, no joke. My former, power-abused VB came with some sort of lamp cord badly soldered to the battery terminals, and inside the controller there were several blown traces which have been jumpered over. What kind of voltage did they use to power this thing? And why did they keep continue using it after blowing traces on the controller board? Anyway it’s so bad that I’ve snapped a couple of pictures to share with you. Oh the horror!

I want to thank everyone who helped me out, especially DogP. Thanks for helping me figure out how the voltage regulator works. Since such information isn’t available anywhere else on the web, I’m going to put it on my electronics/gaming blog so that it can help out other people who might come across a broken VB with the same problem.

Thanks again and happy gaming! πŸ˜€

Congrats on your Franken-VB! πŸ˜‰

That is weird that you found two VB’s that had been monkeyed with! Where did you get them?

Out of curiosity, could you take some pictures of the destroyed display cables? Maybe they could be added to a what NOT to do to fix a glitchy display πŸ˜‰

I really like your blog. It’s well written and I love reading about other people’s hardware hacks (hackaday.com is in my favorites bar πŸ˜‰ ). I can’t wait for the article about replacing the clone’s CPU/PPU. πŸ˜€

That is weird that you found two VB’s that had been monkeyed with! Where did you get them?

I got the first one from a local retro gaming forum. The other one came from the local eBay-like auction site. I’ve paid $10 for the first one and $20 for the second one. Judging by their condition I’d say that both of them have been fished out of flea markets by lucky retro gaming enthusiasts.

I live in Santiago, Chile. My student card doesn’t do PayPal so I can’t buy on eBay, DealExtreme, PlayAsia, etc. (never mind the shipping charges!) Both VBs were scored locally.

The Virtual Boy is a real rarity around these parts. Apparently it didn’t have an official release in my country, which means that the consoles that are floating around have been privately imported from the US. It’s very rare to see one pop up for sale and when they do they’re ridiculously overpriced. I’ve seen glitchy, incomplete VBs sell for as high as $50!

My theory about the monkey-style repairs on both consoles is that they were repaired in the mid 90s, by inexperienced people when the Internet wasn’t everywhere for them to read tutorials and websites like this one. The soldering inside the controller was probably done by a local TV repairman.

Out of curiosity, could you take some pictures of the destroyed display cables? Maybe they could be added to a what NOT to do to fix a glitchy display πŸ˜‰

Check out the attached files πŸ˜‰

I really like your blog. It’s well written and I love reading about other people’s hardware hacks (hackaday.com is in my favorites bar πŸ˜‰ ). I can’t wait for the article about replacing the clone’s CPU/PPU. πŸ˜€

Thanks for your kind comment :-D. I love hackaday too and that was the reason for me to start a blog. I’ve been doing some nifty stuff lately which I felt that needed to be on the web for fellow tinkerers to see. Check out the GameBoy style reset mech. for the NES if you’ve got the chance. πŸ˜‰

I’ll eventually do the clone CPU/PPU swap. I haven’t got around to it because the Virtual Boy and some Famicom Disk System projects have been absorbing my time lately :-P.

Yikes! That really does look like a blow-torch hole! Makes you wonder what goes through someone’s head as they decide to do stuff like that…

I’m glad those two finally found a home with someone who knows how to take good care of them πŸ˜€

I daresay you could probably even fix that torched display cable, if you had some time πŸ˜‰

Also, I actually did read about the NES reset circuit (and watched the video). I even left a comment (two, actually…) that are still awaiting moderation πŸ˜›

Regarding Hack-a-day: have you submitted your reset circuit to their tips line? They would go crazy over it. It’s exactly what they look for in a hack.

Cool… congrats on finding another VB, and finally getting to play it πŸ™‚ . That burn mark on the cable seems REALLY odd… what were they thinking???

BTW, cool blog… I always like reading random electronics/video game hacks, mods, and other related random stuff.


This is a great thread here. I’ve managed to isolate the regulator as the problem. I would have been replacing the board had I not read this, so thank you immensly!!!

I know this thread is 7 years old lol, but does anyone by chance know where I could acquire the components to replace the faulty regulator?



Write a reply

You must be logged in to reply to this topic.