Original Post

Hi all,

My Virtualboy died a couple of years ago. I treid to fix it, but I’ve never found the right screwdriver to open it up.

Now I have the screwdriver! And I openend up my virtual boy. First i thought the u8 dc-dc was broken but now i openend it up. I see there’s a red light burning on it so it seems to work?

Can someone help me?

I openend a topic before which can be found here:

But now i dont think that’s the cause :O!

Sorry for my bad english

8 Replies

Do you hear music when you load up a game? If so, it is the glitchy screen problem, fixable by various methods.


No, I dont hear music and the mirrors don’t start moving. (i have checked the controller and it giver power to the vb.

Hmmmm, a very strange case then, cannot help you on this site unfortunately. Too many variables that can be the problem to just tell you what you can do.
I hope someone else does have a few more pointers, but I am afraid it is not possible with the info you gave.

Go to eBay and buy just the headpiece, those are like $30. Then use yours for parts.

An update! I plugged 4,5V directly into the virtualboy controller port and it booted!

So what now? it must be the controler?

dead-short battery pack or faulty controller… yes. I’d bet its the battery pack as I have had one die, from overally corroded contacts.

Best bet is this auction


I tried to connect a 9 volt addapter to the batterypack pins on the vb but it still doesn’t start. So I think the batterypack is still ok?

yes that means that it is probably your controller and not the battery pack dreammary told me to check with a flashlight for green oxidization on the battery pack contacts inside, so just to be sure you might want to do the same.


Write a reply

You must be logged in to reply to this topic.