Original Post

Okay, here’s my problem: I have a dead Virtual Boy and want to repair it, if possible. I purchased it for $5 on eBay, with the knowledge that it was broken, so I’m not disappointed, but I was wondering if anyone out there had any idea of how to repair it. The problem is that it’s dead. It does not turn on. I thought it was fairly hard to break one of these but it’s broken. There is no sound, no hum of the mirrors, it shows no sign of life. Is this a common problem? Is there something that frequently causes this to happen? If it can’t be fixed, I’ll find some use for it, and $5 was worth it for the stand, but I hate to see another Virtual Boy go to the landfill.

11 Replies

Well, did you try waiting long enough? It literally takes like 5 to 10 seconds to boot up. Also, turn the volume up if you did not already and wait. I thought mine was completely dead too, because I kept switching it off prior to letting it boot up.

Also, see the thing about repairing the led array cables.



I assume you know that the controller/power supply are good? It sounds like it’s not getting power if you don’t see anything happen. If you know the power is good, there’s probably nothing you can do unless you open it up and check for voltage. Inside, on the top of the board there’s a vertical black blob sorta thing which is the DC->DC power supply.

When you turn the system on, you should see a red light shine through the black blob. If you don’t see that, I dunno what would cause that, but it could be a bad connection or a bad DC->DC supply.


I finally got around to testing to see if the batteries are good by using the controller on my good Virtual Boy and they are. The good Virtual Boy starts up fine. The only reason I didn’t test that sooner is that the batteries are almost dead, and I haven’t played my good VB in a while.

Also, thanks for the info about the DC->DC power supply, DogP. I’ll check that as soon as I can get my VB open. (By the way DogP, even the extra long game bits don’t work with the VB; the holes on either side of the cartridge slot are too deep.) I need to find a friend with a dremel.

On a side note, while I was recently replacing the batteries in my VB, I tried using some Ni-Cad’s and learned from experience that their voltage is insufficient to run a VB. Then I tried mixing them with the old mostly dead batteries (3 regulars, 3 Ni-Cads, etc.) and drained the regular batteries (even though they were mostly dead.) At least, the VB doesn’t turn on when I use them now. I hope I didn’t do anything bad.

Anyway, thanks for the info that I didn’t already know! (I hope I can fix the darn thing. 🙂 )

Hey guess what? It must’ve been the batteries because with my new AC adapter it starts up fine…

Heh heh heh…. 😀

Anyway, I now have 2 nearly complete Virtual Boys (one is missing its eyeshade and has a broken stand.) Speaking of which….. are there any good ways to fix a stand? I think I’ll just wrap mine in tape….

Dead Virtual Boy = Sad Kids 🙁

Sorry that was random

That’s also post spam.


So my display is starting to go, and I just received my security bit in the mail. I make it through 9 out of 12 screws to dismantle the thing and the final 3 just aren’t coming loose. They refuse to adhere to the bit, I’m not sure if they’re stripped but I’ll be damned if they’re coming out.

Is this a common problem with dismantling VBs or am I in trouble here?

Did you check if your bits are actually reaching the screws? As I said earlier in this thread, any gamebits that I know of don’t reach down into the screw wells on either side of the cartridge slot… If they did, I’d have repaired the screens on BOTH my VBs by now. (And I even bought the extra long gamebits.) DogP has some guides on how to make your own screwdriver with the use of a dremel, and that seems to work for him. Unfortunately, I don’t have a dremel, so the VB is one of my only Nintendo systems that I can’t open. 🙁

However, if that’s not what’s going on, then just hope that your screws aren’t stripped is all I can say. If they are, then try applying a good amount of downward force on the screws and turning very slowly. And on a final note (not to be insulting, but common mistakes can sometimes cause problems) make sure you’re turning them in the right correct direction. 😀

Hope that helps!

Like I said, I made it through 9 out of 12. The 3 include the one to the left of the eye area on the bottom of the system and the two within the wells next to the control port and the headphone port.

I think I may not be reaching the ones in the wells but I can’t explain why I can’t get that other one.

Sometimes, with these self-tapping screws in ABS, I find that tightening it ever so slightly can make it easier to loosen. Just be careful if you try. If it seems already too tight to even budge, don’t do it. But, if it gives a little, it should be easier to loosen.

I’ve also heard of (but not tried) heating the head of the screw so it softens the plastic on the threads a bit. Wherever I heard about it, they used a soldering iron, but that seems like overkill and hard to do w/out melting the case.

I’ve only gotten two screws out of one of my VB’s, and none out of the other. First I tried a dremelled flat-head, then I modified a brass tube. Both of them only lasted through one screw before wearing out… I’m going to try a steel rod, next time. I just need to go slowly, so I don’t remove the steel’s temper.

Never tried this method, but it may work: http://forums.afterdawn.com/thread_view.cfm/562638 .



Write a reply

You must be logged in to reply to this topic.