Original Post

Hi guys, after thinking by a long time that my FlashBoy was dead I finally realized that it is working after all, but not with my Macbook Pro (2009). I’ve trying flashing it with a virtual machine (VirtualBox) and with Windows 7 (Bootcamp) with no luck, it always throws a “WRITE ERROR” message.

Any ideas?


8 Replies

Every time i’ve gotten that error, it turns out to be the cord i’m using 😛

Ha!, now I’m a little embarrassed :P.

Thanks a lot!.

i’ve had similar issues related to the cord and i do not know why. the cord that came along with the FB+ always works the best.

let us know if that indeed fixed it for you.

The problem was using the cable that came with FlashBoy, it still works with PC machines but not with my Macbook, indeed it never worked with it, that’s why I thought that the cart was broken since up until now I didn’t have a PC to try it again. But after reading bigmak’s suggestion I tried a spare cable that I have and it worked fine with both machines, it even works with VirtuaBox which is of great help too.

BTW: since I’m here, does it works for you when the cart is fully inserted in the VB? I must to remove it first from the VB before the loader recognizes it, is that the normal behavior?

Great to hear that you got it working! 🙂

Make sure to always remove the FlashBoy cart from the Virtual Boy before flashing it! So, yes, the behavious is normal.

Glad to know that is the right behavior.

BTW: when using Dev mode in the loader do you need to pad the ROM first? It’s a lot faster, but think I only got it to work once or twice, so I’m not sure what is the right work flow to speed up testing since flashing with the padded ROM takes a lot more time, but right now it is the only way I can get the skeleton to work on the VB.

I quote the manual found here:

Dev Mode: The Loader has a special option for developers, which allows to flash homebrew ROMs in just a few seconds. First of all load your padded homebrew onto the cart (this sets up the reset vectors at the end of the flash). Then, select “Dev” in the menu under “Mode” and then load your smaller file. Once the reset vectors are in place, the loader just erases and loads the required portion of flash resulting in very low flashing times.

Thanks KR155E, that works… but barely, if I do minuscule changes to the code it works, but as soon as I change more than a line of code it gets stuck at 25% with the WRITE ERROR message. Do you have experience using the Dev mode?


Write a reply

You must be logged in to reply to this topic.