Original Post

Hi, I can’t get Reality Boy to run. Here’s exactly what I did (in ubuntu 12.04)

1. I downloaded the latest source code.
2. Installed Allegro Library.
3. Ran make inside linux source folder.
4. Downloaded Bound High rom, and placed it inside rb folder.
5. Opened terminal and ran “rboy_linux bh.vb -dspmode side -flip -palette red”

But, terminal said it couldn’t find the command “rboy_linux.”
The reason I typed rboy_linux is because that’s the name of the executable file that resulted from the compile. Does anyone know what’s wrong?

4 Replies

Unlike Windows/DOS, Linux doesn’t search for executables in the current directory. Try qualifying the filename, like so:

./rboy_linux bh.vb -dspmode side -flip -palette red

You might also try:

make install

To see if it installs the executable somewhere in the executable search path, which should allow you to run it from any directory using a command-line similar to what you’ve already tried.

OK, I tried both commands, and the first one gave the same error as before, and the second one claimed I didn’t have the permission to modify the usr/bin folder. I’m thinking the second one will work if I can gain permission somehow, but Ubuntu either has no root user or it hides it well!

For permission problems, stick a “sudo” in front of it, like so:

sudo make install

It’ll ask for your password (the one you log in with).

Thanks! It worked finally. But, unfortunately there’s a few other problems. If you need to do other stuff though thats fine because it still works. Here they are: 1. No Sound! 2. I can’t scale the screen with the sclscr command.


Write a reply

You must be logged in to reply to this topic.