Original Post

I can’t get direct screen drawing to work with the latest gccVB (the one that runs under cygwin). I noticed the problem in Yeti3D, but the same is true for DogP’s Etch-A-Sketch.

The code compiles just fine, and the Etch-A-Sketch border shows up, but nothing of what you draw is visible.

This is strange, because the exact same code compiles into a working rom with the older gccVB…

Any ideas?

4 Replies

Have you tried comparing the ROMs (or disassembly listings of them)?

I don’t currently have either compiler installed, so I can’t try it out myself. I hope the problem gets fixed before I do reinstall, though.

It’s been a while, but I think I remember coming across a problem like that, and it ended up being related to something in the libgccvb.h not being declared volatile… but I could be imagining things, or remembering something else. I’ll try to look into it when I get a chance.


Thanks for the tip! I changed the declaration of the VIP_REGS pointer to volatile (which does make sense when you think about it), and now it works! 🙂

Ah… cool, glad that helped.



Write a reply

You must be logged in to reply to this topic.