Original Post

This isn’t really new to anyone who hangs out in the IRC channel, but I’ve uploaded a Mednafen 0.9.0 WIP with Virtual Boy emulation. It currently doesn’t have a debugger(technically it does, but it’s grossly unfinished), but it will eventually.

http://forum.fobby.net/index.php?t=msg&goto=1662

43 Replies

Thank you vey much for this emulator ! It’s perfect !!!

Is it possible to display only red instead of the default 3D blue/red ?

Wow, awesome emulator! And the sound is better than in rb! Thanks!

Is it possible to display only red instead of the default 3D blue/red ?

You can do that by turning off the color of the right eye in the cfg file, like this:

vb.3dmode anaglyph
vb.anaglyph.preset disabled
vb.anaglyph.lcolor 0xff0000
vb.anaglyph.rcolor 0x000000
vb.disable_parallax 1

Then you get a single red screen, like in rboy πŸ˜€

i have trouble to get the emu started on a 64bit win7 machine.
it is not starting at all when i doubleclick the exe.
any suggestions?

Fire-WSP wrote:
i have trouble to get the emu started on a 64bit win7 machine.
it is not starting at all when i doubleclick the exe.
any suggestions?

Like reality boy, mednafen has no gui, so you can’t start it by just clicking the exe. You need to start from a command line, or create a shortcut with the rom filename as a param after the exe file.

I use 64-bit Win 7 too, and it works fine.

ah! i didnt know that heheheh thx.

I’m not sure I’ve said it before, but it bears a public statement, regardless:

Thank you for adding VB support to Mednafen! It totally rocks!

πŸ˜€

The only bug I’ve found in the virtual boy emulation appears in Yeti3D…

There are often these black jagged parts in the walls when you walk up close. Any idea what would cause this? Maybe an error in the bitstring instructions?

Attachments:

For an initial implementation of the Virtual Boy, this is really, REALLY well done. Full speed, native saves and save state support, fast-forwarding… It all works, and it hasn’t crashed on me once yet!

I gotta donate to these guys. πŸ™‚
Edit: except there’s no donate button in sight. Huh.

Donation info was taken down to avoid possible future legal trouble as patent, copyright, and trademark law in a certain country whose name shall Not be Named is ****ing insane and getting worse.

Aw, man. That’s too bad. Did you ever get any legal threats like that? I would’ve liked to “fund” (or just reward) the hard work and time that’s going into this a bit.

Sounds like it could only be USA…

Feel free to PM me the donation details.

A front end would be nice… I just dropped a .vb file on it but couldn’t find the right button to actually start the game in the emulation.

It would be nice to have it work in a few seconds rather than reading and modifying configuration files and such.

Actually, Mednafen has a little GUI you can use to configure it… Just press F1.

It looks like just a help screen to me, and you can’t do much…

The only F-keys that seems to do anything are F1 and the save state key and the snapshot key.

ALT + SHIFT + 1 to “configure buttons on port 1” does nothing…

e5frog wrote:
ALT + SHIFT + 1 to “configure buttons on port 1” does nothing…

It works fine, here. Are you sure a little “Press a key for UP (1)” didn’t appear at the bottom of the screen? Maybe it doesn’t like non-US keyboards, or the specific Shift and/or Alt keys you used. Also, you have to push each key/gamepad button twice (I’m not sure if this is for confirmation or so you can have two keys/buttons for each action).

No the help screen stays the same.

In emulation the only keys that seem to do anything is:
ESC (quit)
F1 (help screen)
F5 (state 0 saved)
F9 (screen snapshot X saved)
Scroll Lock (toggle input grabbing (?))
1,2,3,…0,+ and the next key (- on US Β΄ on mine) (select saved state)
T (debug prompt? #>), quits with (non numeric) ENTER

SHIFT+
F1 (shows three frequencies in the top left corner)
F5 (toggle movie recording)
Scroll Lock (toggle command processing)

ALT+
T (toggle application of cheats)
Enter (toggle full screen)
D (debug, enters assembly language listing)
C (Command prompt for cheats, three options, 1, 2 and D)

left SHIFT + left ALT
(nothing emulation related)

right SHIFT + left ALT
(as above)

left SHIFT + ALT Gr (right ALT)
(as above)

right SHIFT + ALT Gr (right ALT)
(as above)

There’s usually never a problem with using this type of keyboard (Swedish) with US-only software (neither DOS, Windows nor Linux), the mapping is just a little different. Some keys on the right part of the keyboard is mixed up a little, like – * ^ and so. I’m pretty used to using the US-mapping growing up with an Amiga.

Anything else I should try?

Well, ESC actually does nothing.

Is there any documentation somewhere over the keyboard codes in the cfg file, which code corresponds to what key. Since there are keycodes as high as 302 (that’s the highest I found during a fast check) I’m guessing there’s some odd way of decoding them. How many keys are there really in a keyboard – not more than 105 standardbuttons, right?

Is there perhaps some on-line page where I can check these keycodes?

I’ll give this GUI a try then:
http://forum.fobby.net/index.php?t=msg&th=487&start=0&

EDIT … and that can’t really be recommended, it didn’t help with the keymapping at all.

I changed the “Configure buttons on virtual port 1” keyboard code to key 8 instead (56) – it didn’t help.

  • This reply was modified 10 years, 11 months ago by e5frog.
  • This reply was modified 10 years, 11 months ago by e5frog.

I’ve attached my config, so you can compare. I have it set up like the original Reality Boy key mapping (which is now the “alternate” map).

About the key-codes: there are, I think, around 256 possible key-codes on a PS/2 (probably many more on USB) because they’re transmitted in one byte, the high bit is cleared for make, set for break, and there are “extended” codes that are sent as 0xF0 + a second byte. Of course, there are oddities (like the Print Screen), but that’s the gist of it…

However, on top of that, the codes stored in the Mednafen config have to also represent an unknown (unlimited?) number of game-pad buttons, so the key-codes may be translated/encoded, or something. I do know that there is some kind of lag when SDL accesses the keyboard, so it’s not really recommended to use it, if at all possible.

e5frog wrote:
Is there any documentation somewhere over the keyboard codes in the cfg file, which code corresponds to what key.

Only the source-code, I think, and that hasn’t been released for this version (although the code for a recent version may be similar enough).

That helped – I got it to start – thanks!

You’re quite welcome. I only hope Ryphecha can figure out why it doesn’t work for you (and probably others)…

 

Write a reply

You must be logged in to reply to this topic.