Original Post

Hey

I’ve been having the glitchy screens for a long time now and the oven trick works, but I have to do it like every two weeks…
I read that soldering the display helps but I can’t solder (and certainly not that precise) so i was wondering if conductive glue would work?

I guess it works but I’m not sure and was wondering if somebody already tried that.

22 Replies

it’s very unlikely to work unless you can apply it extremely precisely (possibly using a mask like you would with solder paste). Most likely you’ll short multiple pins and make the problem worse. Solder would be much easier because solder will only stick to the conductive surfaces, unlike the conductive glue, which will stick to any surface.

If you short pins with solder, adding flux and reheating (possibly needing desoldering braid) will fix the problem. Conductive glue is much more difficult to work with, and there’s not a good way to get it to just stick to the conductive parts. Either way, you’d still need to remove the coating off the flex cable to expose the conductor.

DogP

I’m going to do it anyway.
I’m gonna remove the plastic with a gilette or with NaOH (or something)
and trying to precisely apply the glue with a needle or something.
Hope it works.

Sounds good… good luck, and let us know how it goes.

DogP

indeed. take pictures if you can 🙂

I found the conductive glue (with silver) but I can’t find NaOH anywhere.
I went to supermarkets and other shops, but I just can’t find it.
Has anybody an idea where you could find it?

It would help if you told us your country of residence… (There’s a setting in your profile for that, BTW.)

Did you check in the bathroom/drain-cleaner section of the supermarket? You could also try the plumbing and/or paint sections of larger hardware stores (it can be used to strip some kinds of paint). It’s also called “lye”, “caustic soda”, or “sodium hydrate”.

How do you plan on applying the glue? I have to echo DogP’s suggestion of soldering. Though I haven’t done either, soldering just seems much easier. I haven’t done it just because I dread the work it would take to (properly, safely) apply the NaOH.

Yeah, if you have a hardware/home improvement store, it should be in the plumbing/drain cleaner section. I know Lowe’s has it (if you’re in the US), and I’m guessing Home Depot, Menards, or whatever other large home improvement/hardware stores would have it too.

DogP

I’m from Belgium (Europe) but apparently you can’t choose that country from the menu, It’s probably too small.

I went to many stores, but the only thing they had were every brand of drain cleaner but not some NaOH.
Then I read you could buy that in an apothekery (for medecines) but they were all closed yesterday.
then I found a drain cleaner at home with 20% NaOH.
I tried it with that but not much had happened.
When I was doing a little peeling with a knife I found that you could peel off the plastic.
I did that and now the copper pins are visible and the plastic is gone.
I only bend some pins but I didn’t break any of them.

Now I’m gonna put the silver glue on it.

This is a picture with the displays and the plastic bend over.

  • This reply was modified 13 years, 6 months ago by virtualboyke.

This is a picture of the glue I’m using.
(27 euros for 3 grams, but with pure silver…)

Attachments:

This is a picture while putting the silver glue on the connections.

Attachments:

This is a finished display.
(I’m going to put a second layer on it after a while.)

Click on the black square to see it (It’s black for me)

Attachments:

Here I have both displays finished.
to make it hold, I wrapped a tiny piece of tape around the silver connections.

Attachments:

OMG!
IT WORKS!
IT REALLY WORKS!

It’s true! I can play games again!
But I have to admit there is still a very small little problem…
There are lines in my screen…
They aren’t bad, but they are still there. (see the picture below, the picture is not from myself, it’s from Dogp’s site I think))
I’m sure if I was a little better then they wouldn’t be there.
So I think that others can try the silver glue as well.

I’m not gonna search for the problem because I’m so surprised and happy it works! Every time before, when I tried to fix something, I broke it. I thought I broke my VB too.
(when you could peel off the cable, it really looked messed up…)

I’m gonna search on the internet which pin is causing this problem and then I maybe gonna replace the silver…
Maybe one of you guys knows which pin is causing those lines?

OMG I’m really happy now…

That moment when “caution” popped up on the screens… that really was exciting… It seemed to take forever to appear when I turned it on.

  • This reply was modified 13 years, 6 months ago by virtualboyke.
  • This reply was modified 13 years, 6 months ago by virtualboyke.
Attachments:

Congratulations, that looks very good! The glue really looks like solder. I hope you can find the pin(s) that are causing the remaining lines. I believe it could be almost anyone though, there is not one specific pin that causes that 🙁

Cool… congrats! That does look pretty nice (that glue looks higher quality/easier to work with than the stuff I’ve got, which is probably why it’s much more expensive too).

But yeah, if you’ve still got lines, either a pin is shorted to another, or one isn’t connected. Are the lines the same on both displays? If so, you have a shorted pin (because both eyes share the same bus). Disconnecting one display will tell you which one is bad (one should look fine by itself, and the other will have the lines). If the lines are only on one display, or they’re in different places, you have a pin(s) not making contact.

BTW, do you have a flash cart? If so, I could throw together a quick test to tell you which pin(s) is bad.

DogP

I may have to look into getting some of that glue myself(have a Saturn mem card with a lifted lead). That looks sweet. Kudos! 🙂

Thanks!
Yeah, it appaers on both displays, AND I have a FlashBoy, so maybe that test can be very helpful!
(If you would make it, thanks, Dogp!)

And with that trick I discovered it was the right display who has the lines.

Well, for that glue, it costed me 27,85 euros (see picture) and I only used 1% or something.
But it’s really good silver glue and it fixed my virtualboy, so I can’t complain!

  • This reply was modified 13 years, 6 months ago by virtualboyke.

Well… since you disconnected the display and found out it’s a short… that should be pretty easy to find if you’ve got a multimeter. You should be able to check continuity between each adjacent pin and find the shorted one, then take a knife, needle, etc and scrape between the pins and hopefully clear the short.

BTW, does it look identical to the picture that you linked from my site (only partial lines), or are they completely horizontal lines (like: http://home.comcast.net/~virtual.boy/projectvb/tech/displayfix/dispwithlines.jpg ), or different than those?

But yeah… I’ll see if I can get some time in the next few days to throw a test app together.

DogP

I don’t have a multimeter or anything like that (I don’t know anything about electricity either…)
And yes, it’s exactly like on the picture in my previous post, partial lines, no lines on the black surfaces.

And I think you could help a lot of people with such a test app!

 

Write a reply

You must be logged in to reply to this topic.