Original Post

In preparation for trying to build my own flash cart, I’m going through the exercise of seeing if I am able to extract ROM data from Mario’s Tennis. However, I’m not having much luck.

I was last week able to read data from a 32k general purpose eeprom chip using a Raspberry Pi, so I tried the same approach to read Mario Tennis — except that there aren’t enough IO pins for the entire 16-bit data bus, so my plan was to just read the even-numbered bytes, then move the data lines, and then read the odd-numbered ones, then interleave the data to produce the final ROM. However, I haven’t had much luck, getting only 0s out of the data pins no matter what address inputs I give it.

To simplify things, I removed the Raspberry Pi altogether and just used it as a 5v power source. Then I grounded all of the address pins to read word 0, and also grounded pins 1,2,33, 59,60 (ground pins), 3-6 (RAM/expansion write and select pins), ran +5 to pins 8, 53, 54 (VCC), 31 (ROM chip-enable), 35 (output-enable), and 36 (BYTE pin up = 16-bit mode).

I’m expecting to see byte 0x7C on data pins 0-7, but they are all still reading low voltage (something like 0.1 volts). I even tried grounding all of the data pins to see if leaving them floating was causing issues.

I’ve confirmed this game still boots, so am I missing something? My understanding is that there isn’t any form of copy protection — it’s an off-the-shelf ROM chip.

1 Reply

Issue was that I was driving OE high when it should have been low.


Write a reply

You must be logged in to reply to this topic.